A new update come up on September 28th, 2015 that includes some bug fixes, compatibility issues,  enhancements, and what is more important a security issue discovered by Sucuri.

You will be able to see all the details at the Sucuri blog, but basically what had happened was that during a routine audit for theur WAF, they discovered a critical stored XSS affecting the Jetpack WordPress plugin, one of the most popular plugins in the WordPress ecosystem.

You can see a complete detail of the plugin update at the Jetpack Changelog page.